Concur Integration Issue Across Multiple Customers - Affecting Expense report ingestion to Appzen

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 13:34 PDT

Update

We are continuing to investigate this issue.
Posted Jun 27, 2025 - 03:21 PDT

Investigating

We are currently observing an integration issue with Concur that appears to be impacting multiple customers. Due to this issue, Expense reports may not be ingested in Appzen.

We are actively monitoring the situation and will keep you informed as we receive further updates from Concur.

For real-time updates on the Concur outage, please refer to Concur’s status page: https://open.concur.com/?data-center=us2

Thank you for your patience and understanding.
Posted Jun 27, 2025 - 00:00 PDT
This incident affected: Expense Audit (Expense Audit).